Dreamweaver program icon.

1. Open the Applications/Adobe Dreamweaver CS4 folder, and double-click the Adobe Dreamweaver CS4 icon.

To start Adobe Dreamweaver in Mac OS X:

Choose Start > All Programs > Adobe Dreamweaver CS4.

To start Adobe Dreamweaver in Windows:

You start Dreamweaver just as you do most software applications.

Dreamweaver allows users to preview webpages in locally-installed web browsers, it also supports languages including ASP, ColdFusion, and PHP.

Languages including JavaScript, and HTML, and various server-side scripting.

For advanced web technologies such as CSS, JavaScript, and various server-side scripting.

WYSIWYG and code-based interface. The latest version, ver 10.0 (or CS4), is also supported.

Dreamweaver CS4 is a comprehensive web development application originally created by Macromedia, and is now developed by Adobe Systems. Apart from a hybrid

Getting Started

Adobe Dreamweaver CS4

Train the Trainer Programme for Adobe Series
For inserting the most commonly used objects like hyperlinks, tables, horizontal rules, etc., use the Common Lobby, Forms, etc. The Common Category in the Insert bar contains buttons such as Common Elements. The Insert panel appears at the top of the other panels, contains several categories, such as Details, Folders, etc.

The Favorites list shows only the assets you've chosen to include in the Favorites list.

The Site list shows all the assets in your site.

The Assets panel provides two ways to view assets: used in a site, such as images, colors, or movies. The Assets panel provides two ways to view the assets. The assets are elements provided by dragging assets to the Assets panel. This panel provides two ways to view and act on the assets.

You need them (select the name of panel in the Window menu).

The right side of the window, by default, displays Panels, you can expand or collapse as needed.

The Document window displays the current document as you create and edit it. The Document window contains all objects and text in the document. You can use the Document window to create and edit your document.

The Property Inspector locates at the bottom of screen, displays properties for the selected object or text and lets you modify those properties.

The Property Inspector contains options for creating and inserting objects such as images, tables, and layers. It also contains options for creating and inserting text, such as headers, footers, and more. You might want to add to your web pages.

Stepping to work in Adobe Dreamweaver:

Familiar with different workspace settings in Dreamweaver.

Identify the panels and work area used in Dreamweaver.

In this lesson, you'll learn how to do the following:

Lesson Overview

Introduction to Dreamweaver CS4

Adobe Dreamweaver CS4
5. Change workspace by clicking the "Designer" label on the Application Bar.

• Which panel can be placed on the Application Bar?
• Can you move them back to original place?
• Different position.

4. Drag the name tag of each panel and move them to

up window, select Close or Minimize/Expand Panel.

3. Right-click the name tag of each panel for the pop-

identifying the default position of each panel.

2. Select different panel items from Window menu.

1. Start Dreamweaver and select Create New HTML from the Welcome screen.

I. Familiar with Dreamweaver CS4

Practise 1.1 Familiar with Dreamweaver CS4

- Browser Screen
- Designer Compact
- Designer
- Code Plus
- Code
- Classic
- App Developer Plus
- App Developer

- Adobe Dreamweaver CS4

Train the Trainer Programme
Click on "Dreamweaver Site" under the "Create New" section of the Welcome screen.

OR

Check Out The "Site" Window.  Get New Site...

Choose Site > New Site...

To create a new site:

The web pages ultimately host the site files for the world to see, and the location of local computer where the web pages are.

The objective of creating a new site is to define the environment of Remote server where site and identify a root folder where you will save all files, images, and other elements for the site.

Creating Site in Adobe Dreamweaver

Use build-in FTP tool to upload/download files.

Familiar with the steps in defining site for local and remote folder information.

In this lesson, you will learn how to do the following:

Lesson Overview

Lesson 2 Site Management
process and want to have full control of the process.

Other Interface, Advanced, is designed for advanced users who familiar with the whole explanation through out the whole process. The interface is suitable for the novices.

Basic Interface is a step-by-step wizard type environment. With detail description and there are two view of interfaces for user to choose in the Site Definition window. The

published on the Web.

This process of define Dreamweaver site includes naming the site, placing the local files
To manage a Dreamweaver site:

1. Change the settings as desired.
2. Select the site name and click Edit.
3. Choose Site > Manage Sites...

Managing Site in Adobe Dreamweaver:

- Highlight the selected folder.
- Click on the right side of Dreamweaver window.
- Your site is shown on the right side of Dreamweaver.

1. The File panel which displays the folders and files of everything is OK.
2. Your remote server pop up menu. Click Next.
3. Click Next. Select none in the How do you connect to Open and then select.
4. Enter a new name for the site, say C:\MySite. Click Next.
5. Make sure "No, I do not want to use a server technology" is selected. Click Next.
6. Make sure Edit Local copies on my machine, then upload to server when ready.
7. Click the folder icon in the right of "Where are your site files?". Click Next.
8. Double check the information of the new site.
9. Click Done if presented on the summary page.

Dreamweaver Site on the Welcome Screen:

1. Start Dreamweaver.
2. From the main menu bar, select Site > New Site... (or Select Create New)
3. The Site Definition dialog box opens. Make sure the basic interface is selected.
4. The Site Definition dialog box opens. Make sure the basic interface is selected.
5. Make sure Edit Local copies on my machine, then upload to server when ready.
6. Make sure "No, I do not want to use a server technology" is selected. Click Next.
7. Select the site name and click Edit.
8. Choose Site > Manage Sites...

Follow these easy instructions to define a new Web site for Dreamweaver CS4 where you can save all HTML files, CSS styles, images and other elements for the web pages.
6. **Click Done to close the Manage Site window.**

5. **Choose Local/Network from the pull-down menu. Specify the location of remote**

4. **Select Remote Info from Category list on the left panel.**

3. **In the Site Definition for remote window, switch to Advanced Interface.**

2. **In the Manage Site dialog box, select the Site that you created previously (i.e.,**

1. **From the main menu bar, select Site > Manage Sites...**

### Practice 2.2: Exchanging Files with Remote Server

### What's WAMP?

WAMP (Windows Apache MySQL PHP) is a free and open source software bundle that can be set up without charge. It is available from Apache, MySQL, and PHP. WAMP is an acronym formed from Windows, Apache, MySQL, and PHP. The WAMP package includes the services of a simple web server to provide dynamic web pages generation. The term WAMP is an onomatopoeia formed from Windows, Apache, MySQL, and PHP. WAMP is a popular choice for developers who want to test their applications in a web environment.

### Setting up Remote Information

![Adobe Dreamweaver CS4 logo]
11. To exchange the files in the files window, select and drag the files/ between the local and remote list box.

10. For convenience, the files panel can be expanded by click the expand to show local file and click the Get/ Put icons.

9. To upload/download files to/from the remote server, simply select down menu on the top right of the files panel.

8. User can switch between remote server and local computer by click the view pull-

7. From the files panel, select the connect to remote host icon ( ) Once the connection is successfully established, the files on the remote host will be listed in the files panel.
To validate the Web page in Dreamweaver:

1. Choose File > Validate > Markup.

Currently, most of the standards adopted in constructing a Web page such as HTML/CSS are drafted and maintained by the World Wide Web Consortium (www.w3c.org). To check if a Web page conforms with the standard of HTML/XHTML, a Collector form as HTML/Dreamweaver, XHTML is the default marking language for a Web page. Although it is hidden in the Design view, the XHTML code can be accessed from the Code view. XHTML is the standard for all well-formed documents.

In Adobe Dreamweaver, a standard is yet to separate from the requirements of well-formed documents, and these all elements must be explicitly closed.

The XHTTP (Extensible HyperText) is a reformulation of HTML 4.01 in 2000, thus to separate the content of a Web document from presentation. The XHTTP elements will be treated respectively, and tags are written in standard. The XHTML consists of tags enclosed in angle brackets, eg. <html>, <head>, <title>, <body>, etc.

To understand HTML (HyperText Markup Language):

- Check if the page conforms to the W3C standard.
- Specify simple style to change color, font size, text alignment.
- Insert text, image, table, list and hyperlink into a Web page.

Lesson Overview:

Lesson 3: Create a Simple Web Page

Adobe Dreamweaver CS4

Train the Trainer Programme
Edit CSS button. The CSS Rule Definition dialog box appears.

To have more options on the style change like background color, border style, click the

Change the size, color, alignment of the text as desired.

menu to "New Inline Style".

Click the CSS label on the Properties Inspector, change the Targeted Rule pull-down.

Highlight the text that you want to change the style.

To modify the style of text:

at the bottom of the window.

Once you add text, you can change its properties in the Text Property Inspector (located

Type desired text or paste text copied in another application.

Position the insertion point where you want to add text.

Open a document in Dreamweaver CS4. Make sure "Design" or "Split" view is selected.

To add and modify text:

processing programs, such as bold, italic, let alignment, and right alignment.

The Property Inspector allows these features found in Word

using the keyboard or by selecting from another document, you modify text by using the

adding and modifying text works much like a word processing program. You add text by

Working with Text
Drag the selection handle to re-size the image.

and bottom edges of the image.

Switch to Design view and select the image. The selection handles appear on the right

To resize an image:

Click OK.

Enter a brief description. You can also provide a link to a file with a longer description.

there. Click Yes.

If the image is not in the site folder, Dreamweaver asks if you want to copy the file.

Select Insert > Image. Locate and select the desired image. Click OK.

Position the insertion point where you want to add an image.

Save the document in your site's local folder.

Open a document in Dreamweaver CS4. Make sure Design or Split view is selected.

To add an image:

In a web format, most images in web pages are either GIFs or JPEGs.

To insert any image into a web page, as long as it is accessible to Dreamweaver and

Working with Image

Adobe Dreamweaver CS4

Train the Trainer Program
Enter the number of rows and columns.

- Select Insert > Table. The Table dialog box appears.
- Place the insertion point in your document where you want the table to appear.
- Open a document in Dreamweaver.

To insert a table:

Appearance and its structure:

- Adding and rearranging a Simple Table

For .jpg extension:

and then select the Types / Filters category. Add Adobe Photoshop CS4 as editor in case the Photoshop icon does not appear in the Inspector, choose Edit > Preferences > Properties Inspector.

You can also edit your image with Adobe Photoshop by clicking the Photoshop icon on the Properties Inspector.

Once the image is highlighted, you can modify the settings in Properties Inspector.
To modify the table:

- Click in the cell. Then select Edit > Select All.
- OR
- Click in the cell. Then drag to select the cell.

To select a single cell:

- Tag to select the row.
- Click in the cell. Then select Edit > Select Parent
- OR
- Click in the cell. Then drag to select the row or column.

To select a rows or columns:

- Select Table.
- Click in table cell, and then select Modify > Table
- OR
- Click the upper left corner of the table or click anywhere on the bottom edge.

To select an entire table:

- Click OK. The table appears in your document.

If you create a table that lists a collection of books, with columns labeled Author, Title, Year, and Year, by default, header rows or columns are bolded and centered.

And, by default, the entire table will occupy the entire page width.

- Select the top row as header.

Make changes to any of the options in the dialog box. For example, setting table width.

Train the Trainer Programme
Click the Edit button. The CSS Rule Definition box appears.

- Click the New Inline Style. 
- Click the CSS label on the Properties Inspector, change the Targeted Rule pull-down menu to New Inline Style. 

Highlight the list that you want to change the style (or select the list) at the Status bar. 

To modify the style of a list:

- Turn off the List Function. 
- When you finish typing the list, press Enter twice to enter another item. 
- Press Enter at the end of each list item to type the next item. 
- Type the first list item.

In the Property Inspector, click the Ordered List button ( ) or Unordered List button ( ) in the Property Inspector.

Place the insertion point in your document where you want to add the list, and then click the Ordered List button or Unordered List button.

Creating Lists and Bullets:

- Press Delete. 
- Row or column. 

To delete a row or column:

- Click in the cell where you want to delete the entire row or column.

To add a new row or column:

- Click in a cell, specify the width (w) or height (h) on the Properties Inspector.
- Move the mouse to the border of the row or column. Drag the mouse to the desired size.

To resize Row Height or Column Width:

In particular, can help you create effective table designs. 

Attention to table borders and cell padding (the amount of spacing between table cells) is important.
To include "http://" in the address, folder icon ( ) to select a file in your local computer. For an external link, remember you can use the pointer to File icon ( ) to select a file in the Files panel, or click the hyperlink in the link field.

- Specify the hyperlink in the link field.
- Select an image, a word, or a phrase of text you want to format as a link.

**To create a hyperlink:**

There are several different types of links in Adobe Dreamweaver CS4. An internal link (page in your site), an external link (link to another site), or site-root-relative link (goes to another document-relative path or file) or site-root-absolute path (goes to another page in your site). An absolute path (absolute pathname) goes to another site.

Creating Hyperlinks:

- Change the value of Start Count. Click OK.

Select List Properties. The List Properties box appears.

- Right-click the first item on the list.

To change the start count of a numbered list:

Select the list category. Make changes as desired, and then click OK.

Adobe Dreamweaver CS4
4. Set the Title of the page to "Understanding the Internet" and highlight yellow as the background color.

3. Once the new page appears, switch to the Design or Split view.

2. Select Create New HTML from the Welcome screen. If Welcome screen disappears, the current contents of the site.

1. Make sure the mysite (created previously) is now available and the File panel shows

Pratice 3.1 Creating a simple Web page

Click OK.

- Select Title/Encoding category, set the Title of the document.
- Select Encoding (HTML) category, change the Page Font, Size, Text color, background color as desired.
- Select Appearance (HTML) category, change the Background color, Page margins, Page borders, Link, Image, Table, list, and hyperlink.

There are two ways of setting page properties, either through CSS (Cascading Style Sheet) or HTML tags.

- Select Modify > Page. The Page Properties dialog box appears.
- Open a document in Dreamweaver.
- To set document properties:

Setting Page Properties

such as default font family, font size, font color, and background color.

You can use the Page Properties dialog box to set page layout and formatting properties.

Adobe Dreamweaver CS4

Train the Trainer Program
17. Attach following hyperlinks onto the bullet:

- World Wide Web Conceptualization
- Web page: Computers and Internal Information

16. Add the following bullet list:

15. Add the header, "Links to More Information", under the list. Specify as heading 2.

Use different bullet types for the sub list. Change the "B" into blue color.

- CTC
- B2C
- B2B

3. Training
   - FTP
   - WM
   - skye
   - ICC
   - Email

1. Communication

14. Add the following numbered list and bullet list:

Internet applications in education can be divided into three broad categories:

13. Type the following text:

Try also other heading size.

12. Add the header, "Applications in Education", under the table. Specify as heading 2.


The Internet is a set of interconnected computer networks that span the globe.

10. Type in the following text in the middle cell.

Copied to the root folder of your site.

9. Insert the image, earth.gif, into the first and third cells. Make sure the image file is

   header.

8. Insert a table with 1 row and 3 cells, specify 0 for the border, 100% width, and no

   margin.

7. Save the document as Internet.html.

6. Add a horizontal rule (insert > HTML > Horizontal Rule) under the heading.

   insert size to 24pt, align to center of the page.

5. Enter the heading of the page, understanding the Internet, change the color to red,
24. Back to Dreamweaver.

- Is there other configuration needed to be set?
- Can others see your page?
- Can others access your page?
- Ask your partner to type the URL, "http://your.ip-address/"

23. Once completed, ask your partner to access your web page from his/her machine.

22. Click the "File" icon (the up arrow) on the file panel to upload files to the remote site. (You can also extend the file panel to use drag and drop features.)

21. Select both Internet Explorer and EarthExplorer on the file panel. (Click the first file to select is established.)

20. Click the connect icon to Remote Host icon on the file panel. Make sure the connection is established.


Software, Corel Draw and Internet Explorer

Links to More Information

- Adobe
- Corel
- Microsoft

Applications in Education

- Application to share the globe
- The Internet is a set of interconnected computer networks
- Understanding the Internet

18. Save the document. Click Preview Icon (Ctrl) on the tool bar to test it in a browser.

- http://www.w3.org
I. Save the document and upload to the remote site.

II. Copy the corresponding HTML code next to the icon and paste it on to your document.

9. Scroll down the validation page and try to locate the "Validate" icon.

Otherwise, scroll down the page to identify the errors. Correct the errors appear on the document, and then resubmit to the validator.

8. If your document is conformed with the standard, the follow page will be shown.

7. Press Check.

6. Click the Browse button, locate and select the Internal/Html.

5. Launch a browser and visit the http://validator.w3.org site. Select Validate by File from the pull-down menu.

4. If you had made any change, save the document.

3. Make sure the Document Type (DTD) is XHTML 1.0 Transitional. If it is not, select it.

2. Open the Page Properties window (Modify > Page Properties...) select the Title.

1. Make sure the Internal/Html is open in Dreamweaver.

Consistency display of a web page across different browsers.

Follow the instructions below to check if your web page is conformed with the W3C standard. The validation process confirms a
In Adobe Dreamweaver CS4, the Cascading Style Sheet (CSS) is created and managed by the CSS Style Panel. There are two modes in the CSS Style panel: All and Current. In the All mode, the Style Panel appears for the whole document. In the Current mode, the panel has three panes: Summary for selection, the panel area, and properties. You can choose and remove styles for the selected object. In this mode, you can edit the styles for a selected object like text.

Experts say that the way these tools are looked for more easily on sites where text appears in different pages. By using an external style sheet—a separate document that holds CSS definitions for different pages—you can make sure that text appearance is consistent across multiple pages. Not only does a consistent appearance look more professional, but usability experts say that the style sheets help in the creation of a consistent web page.

Consistency is defined at the beginning of each web page. A collection of these definitions is defined in Dreamweaver—دافされる. The CSS Style sheet—defines the CSS definitions for the text. Dreamweaver places these definitions in the Style Definition pane in the Property Inspector, such as text size and text color. Certain text properties in the Property Inspector, such as text size and text color, cannot be edited in Dreamweaver, but all text within CSS is defined by Dreamweaver. Every time you change a property, the text will change without inconsistency across browsers.

Inconsistent uses of the browsers may implement the CSS differently which results in inconsistencies across browsers. The latest CSS includes also the documents, tables, and text content from the presentation, including elements such as the colors, fonts, and formatting of a web page. It is primarily objectives to enable the separation of HTML from the look and feel of a web page.

Lesson Overview:

In this lesson, you'll learn how to do the following:

1. Use CSS Style Panel for managing the style of a web page.
2. Inherit inline, internal, and external style sheets.
3. Identify different properties of a style sheet.

CSS (Cascading Style Sheet)
Click OK.

- In the definition, select (this document only).
- From the select Name pull-down menu, select H1 (the tag for Heading 1).
- In the selector Type pull-down menu, select Tag (redefines an HTML element). This
  option lets you add CSS properties to an existing tag.

The New CSS Rule dialog box opens.

To create a new style, click the New CSS Rule button (.addButton) at the bottom of the panel.

- Make sure the CSS Styles panel is open. If it is not, select Window > CSS Styles.

This is what Heading 1 looks like.

To redefine style for an existing format:

Type some text in the document. Select the text and set it’s format as Heading 1 (select
create a new HTML document, save the document, eg Lesson4.html).

Working with Style Sheet

Across your website (even if your site consists of only one page), you can achieve greater consistency
of content on a web page. By using style sheets, you can achieve greater appearance
Cascading Style Sheets (CSS) are collections of formatting rules that control the appearance
of an HTML document. Even if your site consists of only one page, you can achieve greater
cascading style sheets (CSS) are collections of formatting rules that control the appearance
of an HTML document. Even if your site consists of only one page, you can achieve greater

Change the setting in the background category as follow:

- Block
- Line-through
- Overline
- Text-decoration
- Color

Change the setting in the Type category as follow:

- Font-family
- Font-size
- Font-weight
- Font-style
- Line-height
- Text-transform

The CSS rule definition box opens.

Adobe Dreamweaver CS4
and click the trash icon (\(\bigtriangledown\)). To remove the existing property, highlight the property at the bottom of the panel.

To load the CSS Rule Definition box, click the pencil icon in Properties pane.

You can add new properties by clicking the Add Property button.

Clicking the corresponding field, you can modify the value of existing properties by typing in the value.

Expand the Style label in the All Rules pane. Select hi and all the properties for hi are listed in Properties pane.

In the CSS Styles panel, select All mode.

To modify the style sheet:

- **This is What Heading 1 looks like**

  - Format
    - Left: t
    - Right: t
    - Top: solid
    - Bottom: solid
    - Width: same for all
    - Height: same for all
    - Color: #666
  

  - **Border**
    - Left: solid
    - Right: solid
    - Top: solid
    - Bottom: solid
  

  - **Background**
    - Background-color: #666
    - Background-image: none
    - Background-repeat: repeat
    - Background-attachment: scroll
    - background-position-y: 0
    - background-position-x: 0

  - **Exception**
    - list: outside
    - box: block
    - type: none

  - **Positioning**
    - left
    - top
    - bottom
    - right

  - **Overflow**
    - visible

  - **Pseudoclasses**
    - :before
    - :after

- **Click OK. The style is now applied to the text.**
 anywhere in the Web page. The Class Style can be reused anytime. The Period . before the style name indicates that it is a rule of CSS Style Panel.

• The created style’s name (highlight) is listed in the All Rules pane of CSS Style Panel.

• The CSS Rule definition box opens, specify the desired style; eg. set the background color to yellow and 1px solid border: Click OK.

In the Rule Definition, select (This document only). Click OK.

• From the Select Name, type a name, eg. Highlight.

• In the Select Type pull-down menu, select Class (can apply to any HTML element).

• In the CSS Style panel, click the New CSS Rule Icon located at the bottom of pane.

To create a new style (class):

Formatt will be defined by the desired setting.

Highlight the text and change to format to Heading 2. Note that all the Heading 1

A new text with Heading 2

This is what Heading 1 looks like

Add a new line of text under the Heading 2.

To use a CSS style sheet:

Adobe Dreamweaver CS4 Train the Trainer Programme
In this section, you are going to modify the styles of the internship file by changing the default style of heading and color of bullets, adding a fixed background image and widen

Pracised 4.1: Add CSS to internship

- Click Browse, navigate to your saved style sheet, select it and click OK.
- Click the Attach Style Sheet button (_attach) on the bottom of the pane.
- Create a new document and make sure the CSS Styles panel is open.

To attach a style sheet:

- Click OK.
- Specify the name of the style sheet. Make sure the style sheet is saved in the root folder.
- The Move To External Style Sheet dialog box opens. Check the "A new style sheet..." click OK.
- Right-click the selected rules, select Move CSS rules.
- Select the rules from All Rules pane of CSS Styles panel. (use Ctrl/Shift keys to select

To export a style sheet:

- Select the highlighted style listed in Style pull-down box in the Properties inspector.
- Add a new line of text and select some words.
- To apply the class style:
1. Click OK, save the file and preview it from a browser.

2. In the box category, specify the padding value as 10px for all the boundaries.

3. In background-attachment, for background-attachment, select no-repeat for background-attachment, and select the image.

4. Back in the background category, select no-repeat for background-repeat, and select the image.

5. Select the image, go to background-image.

6. In the background category, click the browse button next to background-image.

7. In the Type category, set the color to Green, then click OK when finish.

8. Click OK. All the heading 1 elements in the page will adopt the new setting.

9. Repeat step 2 ~ 5, but select all the tags for bold.

10. In the Type category, set the color to yellow.

11. Repeat step 2 ~ 5, but select all the tags for bullets.

12. Click OK.

To complete these tasks, follow these instructions below.

1. Open the new CSS Rule window (format > CSS Styles > New).

2. Make sure the Internet is open in Dreamweaver.

3. In the Selectors Type pull-down menu, select Tag (tag) (elements in HTML element).

4. From the Select Name pull-down menu, select H1 (the tag for heading 1).

5. In Rule Definition, select (this document only), and then click OK.

6. The CSS Rule Definition box opens. In the Type category, set the font size to 36pt and color to red.

7. In the Type category, select (this document only), and then click OK.

8. In Rule Definition, select (this document only), and then click OK.

9. Option let you add CSS properties to an existing tag.

10. In the Selectors Type pull-down menu, select Tag (tag) (elements in HTML element).

11. Open the new CSS Rule window (format > CSS Styles > New).

12. Click OK.
21. In the Type category, check the none option for Text-decoration.

22. Click OK. Save and preview the file. Now the underline of hyperlink is being removed.


24. For the Selector Name field, click the arrow button next to the text box and select .

25. In the background category, select the background-color as red. Click OK.

26. Across ir. Click OK.

31. However, this selector re: you add CSS properties for the hyperlink when the pointer is over the link.

18. Open the New CSS Rule window (Format > CSS Styles > New).
To add Flash movies (SWF files): Show or some video that documentaries a community event example, you might feed an instructional Flash movie about model rocketry, a slide:

Flash videos (FLV) incorporate video from other sources, such as a video camera. For video to your site, Flash movies (SWF) contain animaled and interactive content, while Flash Movies and Videos:

- Add a rollover image that change when the pointer moves across it.
- Create an Image map to divide an image into different regions.
- Add a Flash movie and Video to the website.

Lesson overview

Lesson 5 Add More Contents to Web Page
To add Flash Video (FLV files):

1. Select Insert FLV dialog box opens.
2. Click the down arrow on the Media button and select FLV in the pop-up menu. The
   Flash Video (FLV) field appears.
3. Insert FLV file.
4. Select placeholders.
5. Save file and preview it in a browser. Note that two extra files need to be copied
   to your site.
6. In the document showing you what visitors will see when they view the page in a
   browser.
7. To test the movie, in the Property Inspector, click Play. Dreamweaver plays the Flash
   video.
8. Make sure the Flash content placeholder is selected.
9. When a visitor opens this page, the browser plays the SWF file.

A Flash content placeholder is a scene from the Flash movie itself, appears in
the place holder.
To create an image map:

An image map is an image that has been divided into regions, or hotspots. When a visitor clicks a hotspot on your web page, an action occurs. For example, another web page opens. An example is a geographic map that links each country in the map to another page on your site or an external website containing information about that country.

Image Maps

6. Save the file and preview it.
5. In the second cell, insert a Flash video, History.html, with desired skin.
4. Move the all the contents of Applications in Education (a) all the numbered and bulleted lists into the first cell.
3. Insert a 1x2 table (Insert > Table), set the width at 100%, no border and no header.
2. Place the Insert point before the text, Applications in Education.
1. Make sure the Internet.htm is open in Dreamweaver.

These tasks.

In this section, you are going to add a Flash video to Internet.htm and use table elements to change layout of the document. Follow the instruction below to complete.

Adobe Dreamweaver CS4
A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: the primary image displayed when the page first loads (the image that appears when the pointer moves over the primary image), and the rollover image that appears when the pointer moves over the primary image.

To edit the existing rollover, click the rollover hotspot (indicated in blue spots) and change the setting in the Properties Inspector.

- To edit the existing hotspot, click the hotspot in your document.
- When finished, click other place in your document.
- Type a descriptive phrase for the link destination in the Alt text box.
- Add a link to a page in your site or to an external URL.
- In the Rollover Property Inspector, do the following:
  - Select one of the hotspot tools located below the Map name, and draw a rectangle.
  - Circle, or polygon, around a part of the image.
  - Drag the hotspot around the image.

In the Properties Inspector, do the following:
- Enter alternate text for the image, and then click OK.
- Tag accessibility attributes dialog box opens.
- Locate an image for the image map. Select it (e.g., map01.gif), and click OK. The Image source dialog box opens.
- Click the down arrow on the Images button and select Image from the pop-up menu.
- Make sure the Common category is selected in the Insert bar.
- Repeat the above steps to add other hotspots in the image map.
new image in the src text field (or click the folder icon and pick the desired image)

- To change the original image, in the Properties Inspector, change the filename of the
  selected image.

- Select the rollover image.

To modify a rollover image:

- Click OK to close the dialog box.
- To be opened when the image is clicked.
  - When clicked, go to URL: Click Browse and select the file (or type the path to the file).
  - Alternate Text: Type the text you want to appear as alternate text for the image.
  - Original Image: Click Browse and select the image to be displayed when the pointer
   rolls over the original image.

- Image Name: Type a name for the rollover image.

The Insert Rollover Image dialog box opens.

- Rollover Image from the pop-up menu.
- Make sure the Common category is selected in the Insert
  image.
- Open the document in which you want to create a rollover

To create a rollover image:

When the pointer passes over it:
- Images are swapped. One example is a button that highlights or changes appearance.
- Click OK. Save and preview the document.

Source To box:
- Click Browse to select the new image file in the Set Images list. Select Image "rolloverImage".
- From the Images list, select Image "rolloverImage".
- Behaviors panel not shown, select Window > Behaviors.
- From the Event list of the Behaviors panel, if the action is then choose Swap Image.
To launch the Extension Manager:

Extending the functionality of Dreamweaver

In this lesson, you will learn how to do the following:

- Extend the ability of Dreamweaver with Extension Manager.
- Access free resources from the Internet.

Lesson Overview

Lesson 6 Extending Dreamweaver CS4

9. Try other Google Gadgets or download other interesting Web Widgets from the Exchange.

8. Preview your Web page with the preview/Debugging tool on the menu bar.

7. Save the Web page as myGadget.html in your site.

Press Done.

- Set Timezone (hours) & UTC in Google Settings.
- Change the content of Title in Display settings.

6. Select Clock & Date gadget from the list and press Next.

5. Click the Google gadget from the list to open the Choose a Gadget dialog box.

4. A Web Widgets option is now listed in the Insert panel.

3. Restart the Dreamweaver and create a new HTML.

Adobe requires you to sign in with your Adobe ID. If you don't have one, please apply one. It is free.

2. Scroll the Adobe Web site and look for interesting Web Widgets.

1. Click the Extends Dreamweaver tool ( ) and select Browse for Web Widgets.

chunk of code that can be installed within a Web page.

manage the Web widgets downloaded from the Adobe official site. A widget is a portable

The Extension Manager not only able to extend the features of Dreamweaver, but also

Practice 6.1 Extend Dreamweaver with Web Widgets

- Select Extension Manager from the Extend Dreamweaver tool on the Application Bar.

OR

Train the Trainer Programme CS4 Adobe Dreamweaver CS4
From others:


Dreamweaver Help and Support - http://www.adobe.com/support/dreamweaver

From Adobe.com:

CS4. Visit the following sites for the details.

There are many resources including tutorials and videos for users to learn Dreamweaver.

Free Resources from the Web.